28 Cyncly

FeneVision® Best Practice

Image to ZPL Code Conversion (BP0127)
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Introduction

This document covers the steps to convert a digital image to ZPL code for use with Zebra Label Printers. This process is
necessary to print any image using ZPL. Common applications of images are for NFRC and Energy Star logos and maps, or
for company logos.

Converting a Company Logo
The steps outlined in this document cover the entire process of converting images to ZPL, including the resizing,
converting, and testing the image data.

Step 1 —Image Editor
Install your preferred image editing software. Paint.net is used in this document, and any screenshots will be from
paint.net, however other image editing software can be used.

Step 2 — ZebraNet Bridge Enterprise Install
Install ZebraNet Bridge Enterprise onto your laptop. The install file is shared in the following directory:
\\fenstore\Software\ BackedUpToAzure\Zebra\Zebranet Bridge\

Alternatively, the ZebraNet Bridge software can be downloaded from Zebra website.

After the installation is complete and you go to open the software for the first time, a window will open asking for a serial
number. Just press “Cancel” and the window will close, and you can continue to use the software like normal.

Step 3 — Backup & Copy
Make sure all original images have been backed up. If any mistakes are made during the image editing process, there
should be a backup copy of each file.

Step 4 — Black & White
Note: Label template “Iblpr41” will be used during the tutorial, however other templates can be used. Sizing will be for the
“Iblprd1” template.

1. Openimage in image editor.

2. Click “Adjustments -> Black and White”
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Adjustments | Effects i
Auto-Level Ctrl+Shift+L
 Black and White Ctrl+Shift+G

p Brightness / Contrast..  Ctrl+Shift+T

& Curves.. Ctrl+Shift+M
= Hue /[ Saturation... Ctrl+Shift+U
[F invert Colors Ctrl+Shift+

Levels... Ctri+L
B Posterize.. Ctrl+5Shift+P
™ Sepia Ctrl+Shift+E

3. Click “Adjustments -> Levels”
4. Inthe new window, drag the middle set of arrows under the “Output” column down until the image turns black
and white, instead of grey and white.
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Step 5 — Resizing

1. Select “Image -> Resize” from the toolbar.
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Image | Layers Adjustments Effects ‘

Crop to Selection Ctrl+Shift+X
[E], Resize... % Ctrl+R
&k Canvas Size... Ctrl+Shift+R

ALk Flip Horizontal

= Flip Vertical

& Rotate 90° Clockwise Ctrl+H
W Rotate 90° Counter-Clockwise Ctrl+G
'w Rotate 180° Ctrl+)

Flatten Ctrl+Shift+F

2. Inthe new window that opens, choose “By absolute size:” under resampling, and make sure “Maintain aspect

ratio” is checked.

a. Change “Resolution” to 300 pixels/inch.

3. After setting the resolution, change the “Width” and “Height” options under the “Pixel size” category to the
desired size based on the chosen label template.

a. Do not change the “Width” and “Height” options under the “Print size” category.

El Resize

Mew size: 54.4 KB

Resampling: Best Quality bl

(O By percentage: 100~ %

(@) By absolute size:

Maintain aspect ratio

Pixel size
Width: I 245‘ = | pixels
Height: 585 pixels
Resolution: 300.0045- pixelsfinch
Print size .
Width: 0.80-2 | inches
Height: 0.195 inches

* Fant will be used

x

4. Select “OK”, and the window will close, resizing the image.
5. Save the image as a JPEG by clicking “File -> Save As” and selecting JPEG from the drop-down menu underneath

the name of the file.

Step 6 — ZebraNet Bridge Enterprise Usage
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Open ZebraNet Bridge Enterprise, and select from the toolbar, “Tools -> Graphics Conversion Wizard”.

% ZebraNet Bridge Enterprise

File Edit View Printer Tools Preferences Help
SEENS r:§>}|_A|Font‘.'\.l'i;:ard | @

Search Groups E SRR i Status | Summary | Visual Alerts | Maintenance

- YR Connectivity Wizard
{4 Searches ] )
= Q @ Copy Printer Wizard

860 SET-GET-DO Wizard

Value

Clear Alert Log

Lo
—

Group Management
B Croues|
=-{_J Local Printers
+-cby, ZDesigner S4M-203dpi ZPL

In the new window that opens, select “Browse” and find the image you resized. Then click “Next”.

el

This wizard converts graphic files to ZPL format.

Select Input File

Browse...

< Back Next > Finish Cancel

Change the orientation of the image on the label if needed. Click “Next” if the orientation is already correct.
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LAt

This wizard converts graphic files to ZPL format.

Select Desired Rotation

(®) 0 Degrees (O 90 Degrees
(O 180 Degrees (O 270 Degrees

@ FeneTech

< Back Next > inish Cancel

4. Resize the image if necessary. Click “Next” when finished.
a. Ifthe image was already resized in an image editing software, then this step can be ignored.
b. If not, the desired height and width of the image, in pixels, must be known for the chosen resolution.

-~
This wizard converts graphic files to ZPL format.
Select Desired Graphic Size
Width in Pixels [currently 240: [240 | Reload Original Image
Height in Pixels [currently 58]: [ 38 l Apply Resizing
Preserve Aspect Ratio
@ FeneTech
< Back Next > inish Cancel

5. Choose the Memory Device and the Filename.

a. For the Memory Device section type “E” (Note: If the Memory Device is set to R instead of E, the image
will not print from the Templates already created).
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b. For the Filename section type the filename.
Make sure the Extension is set to “.GRF (Uncompressed)”.
d. Hit “Next” once Memory Device and Filename have been filled in.

o

LAl

This wizard converts graphic files to ZPL format.

Select Desired Printer File Format and Name

Memory Device: Filename: Extension:
'E |[ TestLoGo | .GRF (Uncompressed)

Black and White Image?

@ reneTech

< Back Next > inish Cancel

v

6

6. Save the ZPL code by clicking “Save” and navigating to an easily accessible location. When finished, click “Next”.
L)
This wizard converts graphic files to ZPL format.
Select Output File
C\Users\luke.rogers\Documents\Graphics - 3.75 x 2.5\TESTLOGO.zpl . Save...
< Back Next > Finish Cancel
7. Choose to convert another image or end the process.
FeneVision® Best Practice Cyncly
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a. To convert another image, click the check box, and select “Finish”, and the window will close and reopen
at Step 2.

b. To end the process, just click “Finish”.

LAl

This wizard converts graphic files to ZPL format.

Conversion Successful

¥ Zebra
[] Check to Convert Another Image

Step 7 — Text Editor
1. Open the ZPL file in a text editor. Notepad ++ will be used for this tutorial, and any screenshots will be from
Notepad ++, however other text editing software can be used.

a. Note: Make sure that the ZPL code is opened in an actual text editor not Windows Notepad. Items that
need to be changed will only show up in the text editor.

BIMEDGE : TESTLOGO . GRFNE17408830M8-U0ANFASh [DGE : TESTLOGO . GRF174030rURPANFA8H|

b. The leftmost line is in Notepad ++ whereas the rightmost line is in Windows Notepad. The two
highlighted lines are the same, however certain symbols only appear on the leftmost line.

2. Change the two symbols appearing below.
a. Change HIE _5 ~ (tilde)
b. Change BE >  (comma)

The file will start out looking like line 1 below. Modify it to look like line 2.

T DIMBDGE : TESTLOGO.GRFEN17408EH308HrUOANFAShLL057 S

s}

2 ~DGE: TES‘TLOGO. GRF,1740,30, rUOANFASB8hLOS/7SFAhHO1

Note: If using Notepad++ you can use the “Find and Replace” to replace both characters at once.
1. Search Mode = “Regular Expression”
1. Find = (03 | (BE3:)
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1. Replace = (?1~)(?2,)

Replace >
Find Find in Files  Find in Projects  Mark
Find what : ()10 v | Find Next | O
Replace with :| 172, V| i Replace
In selection | Replace Al |

Replace All in All Opened

Backward direction Documents

Match whole word only
[IMatch case Close
Wrap around

Search Mode Transparency
(" Mormal (®) On losing focus

(O Extended (n, ', 1t '0, ...) O Always
| (®) Regular expression | . matches newline 1

a. Add the following lines of code to the bottom of the ZPL code for testing.
AXA

ALH10,10
~CF0,30,30

AEX***COLUMN ONE***AFS
AFOO0,07FB200,"FD!PRODDATE!"FS
AFOO0,307FB200~FD!PARTNO,15!"FS
AFOO0,607FB200/FDLine #: ILINEITEMIAFS
AFOO0,90"FB200”FDSched: ISCHEDID!"FS
AFOO0,1252XGE:TESTLOGO.GRFAFS

AEX***COLUMN TWO***AFS
AFO250,0"FB350"FD!ORDERNO!"FS
AFO250,307FB3507FD!DIMENSIONS,25!FS
AFO250,60"FB350"FD!XOFY!"FS
AFO250,907FB350"FDBatch: |BATCHID!FS

AEX***COLUMN THREE***AFS
AFO600,07FB200,1*FD!CUSTOMER, 10! FS
AFO600,307FB200~FD!OPTIONS,10!/AFS
AFO600,60"FB200"FD!PTANDATTR,10!"FS
AFO600,90"FB200"FDBin: |BIN!AFS

AFX***BARCODE***AFS
AFO250,120"BCN,30,N,N,NAFD!BARCODE!”FS

AXZ
b. Replace “TESTLOGO.GRF” with the name of the ZPL file.
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XA

~LH10, 10
~CF0, 30,30

AFX***COLUMN ONE***~FS

~FO0,0"~FB200, "FD!PRODDATE! "FS

~F00, 30"FB200~FD!PARTNG, 15! *FS

~“FO0, 60"FB200"FDLine #: !LINEITEM!"FS
~F00, 90"~FB200"FDSched: !SCHEDID!"FS
“FO0, 125"XGE: TESTLOGC.GRE"FS

AFX***COLUMN TWO***~FS
~F0250,0~FB350"~FD!ORDERNO!"FS
~F0250,30"FB350"FD!DIMENSIONS, 25! *F§
~F0250, 60"FB350"FD!XOFY!"FS
~F0250,90"FB350"FDBatch: !BATCHID!"FS

~FX***COLUMN THREE***~F3
~“F0600,0"FB200, 1"FD!CUSTOMER, 10! "FS
~F0600,30~FB200"FD!OPTIONS,10!"FS
~F0600, 60"FB200"~FD! PTANDATTR, 10!"~FS§
~“FO0600,907FB200"FDBin: !BIN!"FS

AFX***BARCODE***~F§
~F0250, 120~BCN, 30, N, N, N*FD! BARCODE! ~FS

~XZ

Converting Energy Star Images

Step 1 —Backup & Copy

Make sure all original images have been backed up. If any mistakes are made during the image editing process, there
should be a backup copy of each file.

Step 2 — Resizing the Image

1. Openthe image in the image editor.
2. Select “Image -> Resize” from the toolbar.
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Image | Layers Adjustments Effects ‘

Crop to Selection Ctrl+Shift+X
El Resize... N Ctrl+R
&} Canvas Size... Ctrl+Shift+R

Ak Flip Horizontal

=3 Flip Vertical

&) Rotate 90° Clockwise Ctrl+H
&' Rotate 90° Counter-Clockwise Ctrl+G
Rotate 1807 Ctrl+)

Flatten Ctrl+Shift+F
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3. Inthe new window that opens, choose “By absolute size:” under resampling, and make sure “Maintain aspect
ratio” is checked. There are two options to choose from for the resolution based on the final DPI (Dots per Inch)

required.

a. The first option is to change “Resolution” to 203 pixels/inch for a 200 DPI print.
b. The second option is to change “Resolution” to 300 pixels/inch for a 300 DPI print.

=l Resize

MNew size; 3.2 MB

Resampling: Best Quality b

(O By percentage: 1002 %
(@ By absolute size:
Maintain aspect ratio

Pixel size
Width: pixels
Height: 7501=| pixels
Resolution: pixels/inch

Print size
Width: inches
Height: 2.50/= inches

* Bicubic will be used
Cancel

e

4. Do not change the “Width” and “Height” options under the “Pixel size” category. Just change the “Width” and
“Height” options under the “Print size” category to the desired size.

5. Select “OK”, and the window will close, resizing the image..

6. Save the image as a JPEG by clicking “File -> Save As” and selecting JPEG from the drop-down menu underneath

the name of the file.

Step 3 —ZebraNet Bridge Enterprise
See Step 6 under Converting a Company Logo.

Step 4 — Text Editor
1. Openthe ZPL file in a text editor.

2. Change the two symbols appearing below.

a. Change HIE _5 ~ (tilde)
b. Change BB > (comma)

The file will start out looking like line 1 below. Modify it to look like line 2.

1 MMADGE : TEST.GRFEB487 68889 6@BoPF800PF300PF800PFS
2 ~DGE:TEST.GRF,48768,9640PF800PF8OOPFBOOPFBOOPFBO

FeneVision® Best Practice
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3. Add the following lines of code to the bottom of the ZPL code for testing.
a. For 200 dpi:
AXA
ALH15,800
AFO10,5"XGE:IMAPIAFS
AXZ
b. For 300 dpi:
AXA
ALH15,800
AFO30,5"XGE:IMAPIAFS
AXZ
c. Replace !MAP! with the name of the ZPL file.

200 dpi
= TESTZRI EA
1 ~DGE:TEST.GRF, 48768, 96, 0PF800PF800PF800
2
3 XA
4 ~LH15,800
5 ~F010,5"XGE:TEST.GRF"FS
6 ~XZ
300 dpi
EJTEST.szﬂ‘
1 ~DGE:TEST.GRF, 48768, 96, oPF800PF800PF80
5
3 "KA
4 ~LH15,800
5 "F030,5"XGE:TEST.GRF"FS3
6 ~xZ

Testing the ZPL Code
Company Logo

1. Go to http://labelary.com/viewer.html to test the ZPL code.

FeneVision® Best Practice Cyncly 12/4/2025
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Online ZPL Viewer

XA

International Shipping, Inc.
AFX Top section with company logo, name and address 1000 Shipping Lane

"CF0,60 Shelbyville TN 38102
AFO50,50°GB100,100,1004FS United States (USA)
"FOT75,75"FR"GB100,100,100"FS

~F088,88"GB50,50,50*FS

"F0220,50"FDInternational Shipping, Inc.*FS John Doe

~CF0,40 100 Main Street Permit
"F0220,100*FD1000 Shipping Lane"F$ Springfield TN 39021
AF0220,135*FDShelbyville TN 38102°FS United States (USA)

123456

"F0220,170"FDUnited States (USA)"'FS

AF(050,250GB700,1,3*FS

AFX Second section with recipient address and permit information
"CFA,30

*F050,300°FDJohn Doe"FS

"F050,340"FD100 Main Street*FS

*F0O50,380"FDSpringfield TN 39021°FS

"F050,420"FDUnited States (USA)'FS

P OB A0CB1G0,150 S 1234567890

*F0638,340"FDPermit*FS

AFO638,390*FD123456"FS v

"F0O50,500"GB700,1,3"FS P Shipping Ctr. X34B-1
REF1 FOOB47
(& Redraw = [l Addimage  C Rotate REF2 BL4H8

S Permalink £ Open file

5

Print Density: 8 dpmm (203 dpi) ~
Label Size: 4 X 6 inches v
Show Label: 0 (0 =first label, 1 = second label, efc.)

Labels Available: 1

2. Navigate to the ZPL code made in the text editor.
3. Select everything and then copy all the code.
4. Go back to the website mentioned in step 1 and delete the current code inside the viewer.
5. Paste the copied ZPL code into the box, and press “Redraw” to view the image.
a. Set the “Print Density” to 8 dpmm (203) dpi
b. Set the label size to 4 x 1 inches.
FeneVision® Best Practice Cyncly
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Online ZPL Viewer

"CF0.30 30 - IPRODDATE! IORDERNO! ICUSTOMER, 10!
IPARTNO,15! IDIMENSIONS 25! IOPTIONS, 10!

R ) R LINESTEM! IXOFY! IPTANDATTR, 10!

AEXT*COLUMN ONE™™ S SEMEDID! Balch: IBATCHID! Bin: BIN!

"F00,0"FB200,"FDIPRODDATEIFS e —— TNERURCTERRRTOR

AFQO,30"FB200"FDIPARTNO, 151FS @ FeneTech

*FOO0.60"FB200"FDLine # ILINEITEMI"FS
~F00,90"FB200"FDSched: ISCHEDIDI*FS
*FO0,125"XGE:TESTLOGO . GRF*FS

AEXHCOLUMN TWO™* ES
AF0250,0"FB350"FDIORDERNOI'FS
*F0250,30"FB350"FDIDIMENSIONS 251"FS
~F0O250,60"FB350"FDIXOFYI"FS
*F0250,90"FB350"FDBatch: IBATCHIDI'FS

SEX™GOLUMN THREE™FS
~FOB00,0°FB200,1"FDICUSTOMER 101°FS
“F0OB00,30"FB200"FDIOPTIONS 101FS
4FOB00,60°FB200°FDIPTANDATTR, 101°FS
~FOB00,90"FB200"FDBIn: IBINIFS

AFX**BARCODE*FS
AF0250,120°BCN, 30 N N N*FDIBARCODEIFS

XL

[ Redraw [za) Add image C' Rotate % Permalink = Open file

Ly
Print Density: 8 dpmm (203 dpi) v
Label Size: 4 x |1 inches v
Show Label: 0 (0 =first label, 1 = second label, etc)

Labels Available: 1

Energy Star Image
1. Go to http://labelary.com/viewer.html.
Navigate to the ZPL code made in the text editor.
Select everything and then copy all the code.
Go back to the website mentioned in step 1 and delete the current code inside the viewer.
Paste the copied ZPL code into the box, and press “Redraw” to view the image.
a. Make sure to check what “Print Density” the viewer is set for, either 8 dpmm (203 dpi) or 12 dpmm (300
dpi), based on the resolution chosen earlier in the tutorial.
b. For 200 dpi, change the label size to 4 x 7 inches.

ukwnN

Deployment

General
1. Open FeneVision CORE.
2. Navigate to “Setup -> System -> Settings” and look for “Reports_GlobalDirectory”.
3. Navigate to the folder listed to the left of “Reports_GlobalDirectory”.

Company Logo
1. Open the appropriate label template.

2. Navigate to the folder with the newly created ZPL code.
3. Open the new code and copy the image data only. Do not copy the print commands.
4. Go back to the label template and create a few blank lines above the AXA.
5. Paste the image code into those lines.
6. Add the following line of code into the previous print commands so that the image will be displayed.
a. "FOO0,125*XGE:!MAP!IAFS
FeneVision® Best Practice Cyncly 12/4/2025
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b. Be sure to replace !MAP! with the ZPL code filename.
7. The locations defined in the previous line of code will need to be adjusted so that the image can be placed in the
correct location.
8. Save the file.

Energy Star
1. Open “EStarlmageTemplate”.

2. Navigate to the folder with the newly created ZPL code.
3. Open the new code and copy the image data only. Do not copy the print commands.
4. Go back to “EStarimageTemplate” and find the image that is being replaced with the new code.
5. Delete the old image code and paste in the new code in the same place.
a. The locations defined in “EStarGenTemplate” may need to be adjusted so the image is placed in the
correct location.
6. Repeat this process for all images being replaced.

7. Save the “EStarlmageTemplate”.
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